Un petit BUG Avec les Médias

Modérateurs : Animateurs, Heredis

Répondre
Avatar du membre
luclochtmans
Messages : 168
Enregistré le : vendredi 27 mai 2011 16:52
Localisation : 4460 Hollogne-aux-Pierres, Belgique

Un petit BUG Avec les Médias

Message par luclochtmans » samedi 16 nov. 2019 14:09

Pour INFO
PETIT BUG dans la gestion des Médias.
Explication :
Lors de attribution d'une Localité à un événement, je lui attribue UN Média sous forme d'un Blason
Ce Blason est par défaut enregistré au format PNG et placée dans un dossier X
Ce dossier se trouve dans le même dossier que la base généalogique à laquelle il est lié.
MAIS TRAVAILLANT sur plusieurs Bases, ayant des localités communes afin de simplifié et de ne plus multiplier le nombre de fichiers du même Média, j'ai donc regrouper l'ensemble des Médias, Dans un Unique dossier qui est donc devenu commun à mes dix Bases généalogiques traitées.
Reprenant Une à une les bases avec HEREDIS 2020, les Blasons ( Médias ) ne sont plus liés à leur chemin initial.
cela suite au regroupement dans le dossier disons nommé Y qui est donc devenu le dossier principal de tous les Médias communs aux diverses bases.
Je tente donc de ré-associer Le Blason à sa Localité. Pour ce faire :
1 ) j'ouvre le Dictionnaire des médias
2 ) Je choisi le média à réactualiser ( exemple Ar Bruxelles.PNG )
( Dans le dictionnaire des Médias la miniature est bien au format PNG, MAIS son lien [ chemin ] est donc incorrect )
Je clique sur " Mettre à jour à partir de l'original " et en réponse j'obtiens une Notification :
Chemin Non Trouvé
Heredis n'a pas trouvé le médias original "Ar Bruxelles.JPG "
veuillez indiquer l'emplacement de ce média sur votre ordinateur

En résumé cette Mise à Jour ne reconnait pas l’extension PNG puisque par défaut elle me propose de retrouver un fichier JPG

Amicalement
Luc

pbr-heredis
Messages : 464
Enregistré le : jeudi 9 juin 2011 17:14

Re: Un petit BUG Avec les Médias

Message par pbr-heredis » samedi 16 nov. 2019 15:22

Bonjour

Il y a effectivement un soucis, et pas que là où vous le dites :
Capture1251.JPG
Capture1251.JPG (103.4 Kio) Vu 257 fois
Windows 10 v1903 64 bits - 8 Go de Ram
H2019 à jour

Avatar du membre
luclochtmans
Messages : 168
Enregistré le : vendredi 27 mai 2011 16:52
Localisation : 4460 Hollogne-aux-Pierres, Belgique

Re: Un petit BUG Avec les Médias

Message par luclochtmans » samedi 16 nov. 2019 17:21

pbr-heredis a écrit :
samedi 16 nov. 2019 15:22
Bonjour

Il y a effectivement un soucis, et pas que là où vous le dites :
Capture1251.JPG
Bonjour,
J'ai beau regarder votre capture écran et cela ne me fait pas tilt. Je n'arrive pas à obtenir cette fenêtre de propriété, du moins à partir du dictionnaire des Médias.
Bref Oui j'ai constaté un petit dysfonctionnement comme la procédure est expliquée dans mon précédent courriel.
toutefois quans je n'arrive pas à résoudre disons un soucis que je rencontre avec Heredis, Alors je fais appel au Forum.
MAIS dans la plupart des cas j'essaye de trouver la solution par moi même.
Ne voulant ps rester sur un échec j'ai donc réanalysé ce petit dysfonctionnement et j'ai constaté que si je tente la même expérience avec l'option " Vérifier les Médias " via le bouton Outils je ne rencontre plus le même soucis et aussi bien PNG que JPG sont alors correctement reconnus, seul ma première description donne donc le dysfonctionnement rencontré.

Pour le reste comme tout le monde je découvre, et comme chacun à sa propre méthode de travail, les uns touveront que..... et d'autre apprécierons les quelques nouveautés comme dans mon cas la possibilité d'apporter une plus grande précisions sur les lieux et subdivision avec cette possibilité maintenant de déplacer les marqueurs.
Pour obtenir la précision de situation d'un lieuque permet maintenant Heredis, avant je devais faire appel à un utilitaire en ligne appelé MAP-CODE qui lui me permettait d'avoir des coordonnées plus précises.

Je pense aussi que dès la réception de la clé USB j'y trouverais moult infos afin de mieux encore utiliser Heredis.

Amicalement
Luc

Avatar du membre
stehle
Animateur
Messages : 4272
Enregistré le : lundi 20 juin 2011 19:34
Localisation : Suisse
Contact :

Re: Un petit BUG Avec les Médias

Message par stehle » samedi 16 nov. 2019 17:40

Bonjour
Ceci n'est pas nouveau

Si votre image est en *png, *.gif, *.bmp (entouré en rouge) ou que sais-je, celle incorporée dans le bundle (dossier média du dossier *.hmw" sera en *.jpg (entouré en bleu).
Ce qui d'ailleurs m'agace depuis des lustres.
274_PNG-JPG.PNG
274_PNG-JPG.PNG (20.5 Kio) Vu 226 fois
Cordialement
Yves -    
Bénévole
****************************************************************
Core i7 / 16Go RAM / SSD 240Go / W10/ 2560x1440 / Edge & FF /Heredis19.x
Portable Pentium IV / WinXP
iPhone 8 + iPhoneSE + iPad mini / iOS… à jour[/color]

pbr-heredis
Messages : 464
Enregistré le : jeudi 9 juin 2011 17:14

Re: Un petit BUG Avec les Médias

Message par pbr-heredis » samedi 16 nov. 2019 17:44

luclochtmans a écrit :
samedi 16 nov. 2019 17:21
J'ai beau regarder votre capture écran et cela ne me fait pas tilt. Je n'arrive pas à obtenir cette fenêtre de propriété, du moins à partir du dictionnaire des Médias.
C'est parce que c'est une fenêtre windows (clic droit sur le fichier et Propriétés) que j'ai superposée à Heredis

stehle a écrit :
samedi 16 nov. 2019 17:40
Ceci n'est pas nouveau

Ce qui d'ailleurs m'agace depuis des lustres.
Il serait donc largement temps de corriger le tir.
Windows 10 v1903 64 bits - 8 Go de Ram
H2019 à jour

pjmbarre
Animateur
Messages : 3384
Enregistré le : mercredi 20 juil. 2011 10:55
Localisation : Paris

Re: Un petit BUG Avec les Médias

Message par pjmbarre » samedi 16 nov. 2019 17:48

@lucloctmans
Si j'ai bien compris vous avez déplacé en bloc tous vos media originaux de blason dans un même dossier.
Dans ce cas, je vous suggèrerais d'utiliser : l'outil vérification des media. HEREDIS devrait vous lister tous les originaux non trouvés.
Il vous suffira d'indiquer le nouveau dossier où ils se trouvent pours que les liens avec les originaux soient retissés.

vous avez écrit :
Je clique sur " Mettre à jour à partir de l'original "
Cette fonction est à utiliser sur un media dont vous avez modifié l'original (par exemple recadré ou modifie le contraste**) mais que vous n'avez pas déplacé

** édité : ou modifié le nom
Cordialement
Pierre Barré
Imac 21,5"-Intel Core I5 3Ghz - RAM 16Go - OS-X v.10.15 - Rés 4096x2304
HP Pavillon 17,3" - Intel Core I5 - 2,5 Ghz - RAM 8Go - Windows 10 (1809)- Rés 1600x900
ASUS MemoPad7 ME572C - Android 5.0.1 - Rés 1920x1200

pjmbarre
Animateur
Messages : 3384
Enregistré le : mercredi 20 juil. 2011 10:55
Localisation : Paris

Re: Un petit BUG Avec les Médias

Message par pjmbarre » samedi 16 nov. 2019 17:50

Ce qui d'ailleurs m'agace depuis des lustres.
moi cela ne m'a jamais gêné, il suffit de le savoir
Cordialement
Pierre Barré
Imac 21,5"-Intel Core I5 3Ghz - RAM 16Go - OS-X v.10.15 - Rés 4096x2304
HP Pavillon 17,3" - Intel Core I5 - 2,5 Ghz - RAM 8Go - Windows 10 (1809)- Rés 1600x900
ASUS MemoPad7 ME572C - Android 5.0.1 - Rés 1920x1200

Avatar du membre
stehle
Animateur
Messages : 4272
Enregistré le : lundi 20 juin 2011 19:34
Localisation : Suisse
Contact :

Re: Un petit BUG Avec les Médias

Message par stehle » samedi 16 nov. 2019 17:59

pjmbarre a écrit :
samedi 16 nov. 2019 17:50
moi cela ne m'a jamais gêné, il suffit de le savoir
C'est en fait gênant lorsqu'il s'agit d'images de petites dimensions avec des aplats de couleurs, du genre blasons, dans ces cas, les aplats de couleurs qui sont propres en *.png (compression non destructive) subissent des artefacts jpg (compression destructive) et de plus pèsent plus lourd en Ko.

En voici un exemple frappant. À droite le png original, à droite le jpg du "bundle"
png-jpg.PNG
png-jpg.PNG (32.99 Kio) Vu 215 fois
Et un autre, visualisé d'une autre manière
blasons.PNG
blasons.PNG (11.79 Kio) Vu 214 fois
Cordialement
Yves -    
Bénévole
****************************************************************
Core i7 / 16Go RAM / SSD 240Go / W10/ 2560x1440 / Edge & FF /Heredis19.x
Portable Pentium IV / WinXP
iPhone 8 + iPhoneSE + iPad mini / iOS… à jour[/color]

pjmbarre
Animateur
Messages : 3384
Enregistré le : mercredi 20 juil. 2011 10:55
Localisation : Paris

Re: Un petit BUG Avec les Médias

Message par pjmbarre » samedi 16 nov. 2019 18:34

Pour ma part je n'ai rien constaté de tel (sur Mac).
Il est vrai que mes images de blasons ont un poids nettement plus élevé que les votres (x 10)
Fichiers joints
Capture d’écran 2019-11-16 à 17.13.07.png
Capture d’écran 2019-11-16 à 17.13.07.png (1.14 Mio) Vu 186 fois
Cordialement
Pierre Barré
Imac 21,5"-Intel Core I5 3Ghz - RAM 16Go - OS-X v.10.15 - Rés 4096x2304
HP Pavillon 17,3" - Intel Core I5 - 2,5 Ghz - RAM 8Go - Windows 10 (1809)- Rés 1600x900
ASUS MemoPad7 ME572C - Android 5.0.1 - Rés 1920x1200

Avatar du membre
luclochtmans
Messages : 168
Enregistré le : vendredi 27 mai 2011 16:52
Localisation : 4460 Hollogne-aux-Pierres, Belgique

Re: Un petit BUG Avec les Médias

Message par luclochtmans » samedi 16 nov. 2019 18:55

pjmbarre a écrit :
samedi 16 nov. 2019 17:48
@lucloctmans
Si j'ai bien compris vous avez déplacé en bloc tous vos media originaux de blason dans un même dossier.
Dans ce cas, je vous suggèrerais d'utiliser : l'outil vérification des media. HEREDIS devrait vous lister tous les originaux non trouvés.
Il vous suffira d'indiquer le nouveau dossier où ils se trouvent pours que les liens avec les originaux soient retissés.

vous avez écrit :
Je clique sur " Mettre à jour à partir de l'original "
Cette fonction est à utiliser sur un media dont vous avez modifié l'original (par exemple recadré ou modifie le contraste**) mais que vous n'avez pas déplacé

** édité : ou modifié le nom
OUi c'est exact, j'ai tout concentré dans un dossier unique pour toutes mes bases comportant des Blasons.
Ne voulant pas resté sur un échec j'ai cherché et comme on dit qui cherche trouve et comme vous le dite avec la fonction Vérifier les Médias, je n'i pas rencontré de problème. J'en prends donc bonne notes.
Merci pour votre réponse et confirmation de ma trouvaille.
Amicalement
Luc

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité